Permission Denied, this webpart requires a higher trust in the web configuration file.

May 7, 2008 at 11:15 AM
Having deployed the solution, the web part returns this error. I've checked web.config and the part is listed in the safecontrols section, is there anything else I need to adjust? Thanks.
Coordinator
May 27, 2008 at 4:47 PM
Possibly - try setting the trust level to "Full" (search for "trust level=") or place the assembly (.dll file) in the GAC, c:\windows\assembly. Thereafter, do an IISRESET with command prompt.

Phil
Sep 4, 2008 at 4:58 PM
Edited Sep 4, 2008 at 5:39 PM
Hi Phil,

I made the modification to the webconfig file to no avail.  I am still getting the same error.

Oddly enough, I have no problem using the RSS Reader on a different Team Site hosted on the same port number.

Where do you get the .dll file from?  The download only includes the .wsp file.

I would like to try option 2 if I can.

Thank you!
Sep 8, 2008 at 7:27 PM
Edited Sep 8, 2008 at 7:30 PM

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.wsp]
@="CLSID\\{0CD7A5C0-9F37-11CE-AE65-08002B2E1262}"
"InfoTip"="Contains compressed files"

[HKEY_CLASSES_ROOT\.wsp\PersistentHandler]
@="{098f2470-bae0-11cd-b579-08002b30bfeb}"

use this reg file to open *.wsp

Add this file and restart explorer.exe

Coordinator
Sep 16, 2008 at 3:45 PM
tmf123 - the dll should be deplyed to the bin of the web application when you deploy the solution. If you didn't do that or don't want to, you can change the extension of the .wsp file and rename it to .cab. Double click on it and you'll see the dll in there, and you can copy/paist it out of there. Hope that helps!$0$0$0$0Phil$0
Feb 8, 2010 at 5:44 PM

I've tried the last suggestion, but the web part is not appearing anyplace within my site now.  I did remove the deployment and just copied the file into the assembly directory.

Mar 19, 2010 at 2:36 PM

Heya,

I am new to SharePoint so please apologize if I haven’t used the correct terminology.

I have downloaded the RSSReaderWebPart and installed on the MOSS 2007. Followed the instruction and all went fine.I added the webpart to one of my sites.  The following error occours and I don't know how to fix this.

The remote name could not be resolved: 'www.google.com'

            Refresh Data

 Please could someone let me know how to fix this issue?

The RSS viewer part that is available out of the box uses Kerberos but the SharePoint implementation I work does not use Kerberos instead it uses NT authentication. This was the only reason why I am trying to use this webpart.

Thanks

Shiva S